FAQ

Data appears in TLP but not in SQL reports

This is usually an issue of ‘bad data’, some records are not allowing the database to sync with SQL. Thus, not all the data is appearing in your reports. Currently you will need to contact Logistics Consultants support and they will be able to help with your data.

Backup script not running

When attempting to run a backup (eg before server upgrade or significant data entry) the following is seen at the DOS prompt.

MissFile

  1. Ensure you are using the latest backup script version. (all scripts are updated following a TLP upgrade)
  2. Ensure that the root.tar.gz file is in webapps
  3. Ensure that c:\Mongodb\bin has been added to the system path

I see different results when I use Chrome, IE or Firefox browser The only browser TLP supports is Chrome. Other browers will work for the majority of functionality but do give the odd unexpected result. When viewing SQL reports IE is recommended.

I see this error when I open TLP in my browser

Browser

The application was launched with the full URL. TLP simply needs to directed at the .war file on the web server and will complete the URL itself. So in the browser simply type or bookmark http://<server><port>/transport

Cannot restore a database after I backed it up using the scripts

There have been times when the mongo database corrupts when we try to restore a backup. Therefore once a backup has been taken it may be necessary to ‘drop’ the old database before running the restore script to produce the new. The easiest way to do this is within Mongo from the command line issue the mongo command to drop the database (db.dropDatabase()) and then run the restore script.

I keep getting logged out of TLP

TLP uses session IDs based on the host (server) of your TLP. So for example, if you have both a ‘Live’ and ‘Test’ system running on the same server and log in to both using the same login then you may log yourself out of one when you log onto the other. The way to resolve this is to set up a reverse proxy

Set up the hosts something like this –  request llive.tlp.something.com (default port 80) and get directed to something.com:8099. This will probably need to be done by your network administrator.

I can download the TOBY module but it will not install on my device

There is a known issue when trying to install TOBY onto an Android 6 device – only devices that have currently been reported with the issue. Although the module “downloads” successfully from the website it does not install. The user is presented with a ‘App not installed’ message.

The solution is to edit the downloaded APK file. The file needs editing to ‘internal’ installation and not the default setting. To achieve this you will need to download an APK editor from Google play and then edit the apk file. Once you have edited/saved the apk file then you can install the app.

This youtube video shows the process clearly. https://www.youtube.com/watch?v=xAwzKXg-00c

This is only an interim fix, the development team are working on fixing the apk file at source.